Invoice Printing through MS Word using Tally Productivity Suite feature

Discussion in 'General Discussions' started by Abhilash S, May 3, 2024.

    
  1. Abhilash S

    Abhilash S New Member


    Dear team,

    I'm trying to print the Invoice from Tally through MS Word using the Productivity Suite feature. But it is not working in the client's system. When giving the print command from Tally it is giving the error as "Incomplete Resource Specification". Does anyone have any idea about the reason for this error ?
    Could this be due to the particular version of the MS Office used by this client ? I tried in two MS Office versions at the client end viz. Microsoft Office Professional Plus 2016 & Microsoft Office Professional Plus 2013 and it is the same error in both the systems.

    I also tried with a new Word document file from the client system itself, instead of the Word XML file copied from my system, still it is same error.


    Screenshot of the error:
    upload_2024-5-3_13-43-41.png

    MS Office version:
    upload_2024-5-3_13-45-7.png
    upload_2024-5-3_13-45-37.png

    Any support on this would be highly appreciated.

    The reason I'm trying the Productivity Suite feature is when using the direct print from Tally (using the Tally Export option as well as Print to PDF option using Microsoft Print to PDF/Bullzip PDF Printer/Cute PDF Printer etc) the grid lines are missing.

    Thank you,
    Abhilash S
     


  2. Himanshu-2002

    Himanshu-2002 Active Member


    Tally is unable to find the WordXML File Path, Try entering full file path of Word File
     
    Abhilash S likes this.


  3. muthusundar

    muthusundar New Member


    The Sales ledger field will not appear below the Party A/c name field when: The transaction is recorded with voucher class in the accounting invoice mode. The option Select common Ledger Account for Item Allocation is disabled in the sales Voucher Configuration screen.
     


  4. Abhilash S

    Abhilash S New Member


    Dear team members,

    Thank you for your response. Actually I was able to solve the issue by hard-coding the WordXML file path in TDL. Earlier I had specified the file path in a UDF in Voucher Type master and was calling it using a System Formula and I'm still not sure why it was not working on the customer's system but was working on mine.
    Anyway thank you..
     


Share This Page